\

Add new comment

don't be fooled by MOTU bragging about 64 bit compatibility. yes it runs 64 but if
you have ANYTHING running in 32 DP8 will not recognize it. there is no integrated
bridge and MOTU planned it that way. amazing disrespect to users who work with
VI and plugins in both format.

Close

Close

Close