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 Welcome to onOne Software Perfect Mask 5 User Guide

Perfect Mask is the next generation of Mask Pro, the
leading software for background replacement. Perfect
Mask takes the core strengths of Mask Pro to another
level, by automating many common masking tasks with
incredible accuracy.

Perfect Mask's new masking technology makes selecting
subjects and isolating backgrounds surprisingly easy. With
Automatic Background Removal, an initial mask is made on
your image and can then be fine-tuned using the Erase
and Refine Tools. With these new features, you can
create high quality masks in just a few clicks. You'll be
amazed at how well this works even when masking tough
subjects like hair and glass on complex backgrounds.

Perfect Mask 5 works where you do with seamless
integration into your workflow whether you use
Lightroom, Aperture or Photoshop. It even works as a
standalone application.

Looking for Information? 
If you're unable to find what you're looking for in this help
system, try these alternative resources, or contact our
customer support department.

Most popular pages

Welcome
Keep, Drop and Refine Brushes
What is New Perfect Mask
Using Perfect Mask
Additional Resources
Viewing the Mask
Magic Brush and Colors
Opening Perfect Mask
System Requirements
Contacting onOne Software
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Using this Help System

The user guide for Perfect Mask is presented in html and is readable in most web browsers. When you access the user guide from the help menu it will appear in
your default web browser.

On the left side you will see a table of contents that makes it easy to find the section you are looking for. The table of contents are hyperlinks that will take you
to the specified section by clicking on them. The main body of the page will show you the content you have requested. Use the scroll-bar at the right to scroll
down for additional content. You may see additional hyperlinks in the body text. They will be blue and underlined. Clicking on one of these hyperlinks will take
you to more relevant information.

You use the same forward and back buttons in your browser to navigate this user guide as you would a regular web page. You can even bookmark pages so
you can find them quickly in the future.

If you don't see what you are looking for in the table of contents, try the search field. You can type in what you are looking for and an index of pages will be
created automatically that contain your search term.

Printing the Manual

You can also access a printable version of this manual here. It is in Adobe Acrobat (PDF) format. You will need a copy of the free Adobe Acrobat Reader to view
it.

  

See also
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Additional Resources

Check the Hot Topics

Check the list of Hot Topics on the onOne website. The covers the most commonly asked questions.

Knowledge Base
Search the Knowledge Base for common bugs, tips & tricks, and compatibility issues with other software.

Video Tutorials
Check the online video tutorials.

Technical Support
Contact technical support by filing out a request form.

See also

Using this Help System
Contacting onOne Software
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Contacting onOne Software

onOne Software, Inc.
15333 SW Sequoia Parkway Suite 150 
Portland, OR 97224

Phone Main: 503-968-1468
Fax: 503-968-1469

http://www.onOnesoftware.com

For Technical Support please visit: 
http://www.onOnesoftware.com/support

Sales 
For sales please call 1-888-968-1468

 

See also

Using this Help System
Additional Resources

© 2008­2011 onOne Software, Inc. All rights reserved. onOne Software is a registered trademark of onOne Software, Inc. The onOne Software logo, and
Perfect Mask are trademarks of onOne Software, Inc. Adobe, Photoshop, Photoshop Elements, Photoshop Lightroom, Flash and Acrobat are trademarks of
Adobe Systems, Incorporated. Mac OSX, the Mac logo and Aperture are trademarks of Apple, Inc., registered in the U.S. and other countries. Microsoft,
Windows, Windows XP, Windows Vista and .NET are registered trademarks of Microsoft Corporation. All other trademarks are the property of their respective
owners.
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Home > Installation

Articles in this section
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System Requirements

 Macintosh Windows 

Operating
System 

 Mac OSX 10.6, 10.7 (current maintenance releases)
 Windows XP, Windows Vista, Windows 7 (current
maintenance releases)

 Processor Intel Core 2 Duo or better  Intel Core 2 Duo or better

 Memory  4 GB RAM (8 GM recommended)  4 GB RAM (8 GB recommended)

 Hard Disk  100 MB Hard Disc Space  100 MB Hard Disc Space

 Display
 OpenGL 2.0 capable video card with 256 MB dedicated
VRAM running at 1280x800 or higher

 OpenGL 2.0 capable video card with 256 MB dedicated
VRAM running at 1280x800 or higher

 Optional Host
Applications

Adobe Photoshop CS4, CS5
Adobe Photoshop Elements 9, or 10
Apple Aperture 2.1 or 3
Adobe Photoshop Lightroom 2 or 3

Adobe Photoshop CS4, CS5
Adobe Photoshop Elements 9, or 10
Adobe Photoshop Lightroom 2 or 3

 Other

Internet connection for activation, auto updates and
video tutorials
Adobe Flash 10 player
DVD drive for installation from disc
Administrator privileges to install and uninstall

Internet connection for activation, auto updates and
video tutorials
Adobe Flash 10 player
DVD drive for installation from disc
Administrator privileges to install and uninstall
Microsoft .NET 3.5 framework or higher (installed
automatically if missing)

 

Home > Installation > Installation

Installation

To install Perfect Mask, double click the installer icon and allow the installer to guide you.

IMPORTANT: YOU MUST CLOSE LIGHTROOM AND APERTURE BEFORE INSTALLING.

Mac OS X

The application and all other required files and documentation are installed in the Perfect Mask folder in the user's Applications directory.

The default installation installs all necessary files into all supported versions of Photoshop Lightroom found during the installation process.

If a previous versions of Perfect Mask is found, it will be replaced.

Support files and frameworks are installed into /Library/Application Support/

Windows Vista and Windows 7

The application and all other required files and documentation are installed in the Perfect Mask directory in the onOne Software folder in Program Files.

The default installation installs all necessary files into all supported versions of Photoshop Lightroom found during the installation process.

If a previous versions of Perfect Mask is found, it will be replaced.

Support files and frameworks are installed into \ProgramData\onOne Software\

Windows XP

The application and all other required files and documentation are installed in the Perfect Mask directory in the onOne Software folder in Program Files.

The default installation installs all necessary files into all supported versions of Photoshop Lightroom found during the installation process.

If a previous versions of Perfect Mask is found, it will be replaced.

Support files and frameworks are installed into \Documents and Settings\All Users\Application Data\onOne Software\
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See also

System Requirements
Activation and Registration
Uninstalling
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Activation and Registration

Perfect Mask will operate as a trial version for 30 days from when it is installed. If you have purchased Perfect Mask, you will want to license it so you can
continue to use it past the trial period. When you install Perfect Mask it will prompt you to license it. Simply click on the license button and enter your license
code. Your license code can be found in your order confirmation email if you purchased Perfect Mask electronically or on a sticker on the information card in the
boxed version. Your license code allows you to install Perfect Mask on two computers. When you enter your license code, Perfect Mask communicates with the
onOne activation server and will activate your software. Your software must be licensed and activated to function past the trial period. If the computer you are
activating does not have access to the internet, you can manually activate your software by following the manual activation instructions in the license dialog.

If you wish to move your copy of Perfect Mask from one activated computer to new computer you will need to deactivate it first. Deactivation is a simple
process. Simply open Perfect Mask and select deactivate from the Help menu. This will deactivate Perfect Mask on the current machine, allowing you to install
and activate it on another machine. 

If you lose your activation code, have your computer stolen and can not deactivate it or have other activation issues please contact onOne customer service at
888-968-1468 or visit the support section of the onOne software website http://www.ononesoftware.com/support. 

It is important to register your copy of Perfect Mask so we can provide you with the best possible service. Registered  users of Perfect Mask are eligible for
technical support, information regarding new versions and products, discounts and special offers on new products.

See also

System Requirements
Installation
Uninstalling
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Uninstalling

To uninstall Perfect Mask follow these instructions: 

Windows 

1. Deactivate Perfect Mask by launching it and selecting deactivate from the Help menu

2. Quit Photoshop

3. Click on the start menu and select Control Panel

4. Double-click on Add/Remove programs

5. Select Perfect Mask and click remove 

Note: these instructions are for Windows XP, the steps for Windows Vista are similar. 

Macintosh

1. Deactivate Perfect Mask by launching it and selecting deactivate from the Help menu

2. Quit Photoshop

3. Navigate to the Plug-Ins folder of your host applications. For example: Applications/Adobe Photoshop CS3/Plug-Ins

4. Locate the Perfect Mask folder and move it to the trash

5. Navigate to the Perfect Mask support files and frames located at Library/Application Support/onOne Software/

6. Move the Perfect Mask folder to the trash

7. Navigate to the Applications folder and move the Perfect Mask folder to the trash

See also

System Requirements
Installation
Activation and Registration
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What is New Perfect Mask

The next generation of the popular Mask Pro 4

High quality masks in just a few clicks

Automatic subject detection creates initial mask

Works great on tough subjects like hair and glass

Works directly with Lightroom, Aperture or Photoshop

 

 New Keep and Erase Tools

With the Keep and Erase Tools you loosely brush areas you want to remove, like a distracting
background, and Perfect Mask automatically expands your brush stroke to similarly colored and
textured areas. This is a huge time saver! And, on consistent backgrounds this can be done in as
little as a single brush stroke.

 New Refine Tool

Mask through subjects that were time consuming to mask before with a simple swipe of the Refine
Tool.

In tough areas like hair, tree branches and wedding veils you can simply brush with the Refine Tool
to automatically remove the background and any color fringes.

 

New Background Library

The new library of high quality backgrounds provides you with an easy way to replace an unsightly background in an otherwise great image. Imagine putting your subject at the bottom of a waterfall or
in an old warehouse. Choose from skies, sunsets, walls and muslin backgrounds, just to name a few. Get creative!
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New Automatic Solid Background Removal

If Perfect Mask detects a solid color background, it can remove it automatically. This means that if
you shoot on a solid color, all the masking work is done for you! This is perfect for green-screen
shooting.

 

 

 

New Flexible Previews

Now you can view your mask and the image side by side so that you can see the results in real time.
This is a big time saver because you no longer have to toggle masks on and off to check your work
as you go.

Select the preview configuration that works for you. There are six different ways to look at your
mask to make adjustments and judge quality.

6 . What is New Perfect Mask
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Maintains Classic Workflows

Mask Pro customers can continue to use the tools they are comfortable with but will reap the
benefits of incredible new features that make masking easier than ever. Perfect Mask includes all of
the tried and tested tools from Mask Pro like the keep and drop droppers and the MagicBrush.

 

 

New Works Where You Do

Perfect Mask works directly with Lightroom and Aperture and even as a standalone application. It
also works as a plug-in to Adobe Photoshop and Adobe Photoshop Elements.
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Getting Started
This getting started section will give you only the basics of using Perfect Mask. If you have never used Perfect Mask before this is a good place to start. You
might also try watching the getting started video tutorial. For detailed information on steps and controls mentioned in the getting started section see the Using
Perfect Mask section instead.

Articles in this section

Supported File Types
Opening Perfect Mask
User Interface
Navigating the Preview
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Supported File Types

When used through Photoshop or Photoshop Elements, Perfect Mask supports any 8 or 16 bit RGB file that can be opened by Adobe® Photoshop®. This
includes Jpeg, PSD and TIF as well as Raw files from digital cameras and many other formats. If you routinely work in Grayscale or CMYK, simply convert your
image RGB before using Perfect Mask.

When accessed through Lightroom or Aperture, your images will automatically be copied and converted by the host application into Photoshop (PSD) files.

When accessed as a standalone application or through the Perfect Photo Suite, Perfect Mask supports reading of the these formats.

Photoshop (PSD or PSB)

Tiff (TIF)

Jpeg (JPG)

Raw files from most digital cameras

Perfect Mask saves its files are layered Photoshop files. You can export these to Tiff and Jpeg as well.

Perfect Mask may work on your original target layer or a copy the target layer. It may also work on the actual pixels or a layer mask. Generally it is
recommended to work on a copy of the target layer with a layer mask.

Using Perfect Mask on Smart Objects in Photoshop

Perfect Mask can edit the layer mask on Smart Objects in Photoshop. It will not work on the layers pixels directly. Layer mask is the only available output option
when working on a Smart Object.

See also

Opening Perfect Mask
User Interface
Navigating the Preview
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Opening Perfect Mask

 

Opening Perfect Mask Standalone Application

1. Open the Perfect Mask Application. On Mac OSX it will live in your
Applications Folder, on Windows it will live in your Start menu.

2. When the application opens, it will prompt you for which file you would like to
work on.

3. Perfect Mask starts in the Layers module. Load your new background and
align it in relation to your foreground.

4. Next, select the Mask module from the module selector.

5. Make your desired adjustments, then press Apply.

6. You will be returned to the Layers module.

7. Select Save to save your file.
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Opening Perfect Mask inside the Perfect Photo Suite

1. Start by opening the Perfect Photo Suite application. On Mac OSX it will live
in your Applications Folder, on Windows it will live in your Start menu. You
can also access the Perfect Photo Suite inside of Lightroom or Aperture as
detailed above.

2. The Perfect Photo Suite starts in the Layers module. Think of this as the
home base where you open and save your files.

3. Open the image(s) you wish to work on. You can do this from the File >
Open menu or by using the Browser.

4. Open your new background and align it under the foreground image.

5. Select Perfect Mask from the module selector in the upper right corner

6. Make your adjustments in Perfect Mask, then press the Apply button

7. Your image will return to the Layers module, Save your work using the Save
command in the File menu.

 

 

Opening Perfect Mask in Photoshop

1. When you use Perfect Mask inside of Photoshop you need to open an image
first with your new background on a layer under the foreground layer.

2. When you have the image you would like to work on be sure to select the
layer that you would like to start with.

3. Then go to the onOne Panel and select Perfect Mask.

 
 If you don't see the onOne panel, you can open it from the
Window > Extensions menu. 

You can also access Perfect Mask from the File > Automate menu.

 

 

Opening Perfect Mask in Photoshop Lightroom

1. When you use Perfect Mask inside of Photoshop Lightroom you need to
select an image to start.

2. Then select Perfect Mask for the File > Plug-In extras menu.

3. Perfect Mask starts in the Layers module. Load your new background and
align it in relation to your foreground. If you selected your foreground and
background at the same time in Lightroom you can arrange and align them in
the Layers module.

4. Next, select the Mask module from the module selector.

5. Make your desired adjustments, then press Apply.

6. You will be returned to the Layers module.

7. Select Save to save your file, then select close to return to Lightroom.

 

 If you are using Perfect Mask as part of the Perfect Photo Suite, select
Perfect Photo Suite instead, then select Perfect Mask from the module
selector. Don't select multiple images unless you wish to merge them into a
single layered file.

 

 

Opening Perfect Mask in Aperture

1. When you use Perfect Mask inside of Aperture you need to select an image
to start.

2. Then select Perfect Mask from the Image > Edit with... menu.

3. Perfect Mask starts in the Layers module. Load your new background and
align it in relation to your foreground. If you selected your foreground and
background at the same time in Aperture you can arrange and align them in
the Layers module.

4. Next, select the Mask module from the module selector.

5. Make your desired adjustments, then press Apply.

6. You will be returned to the Layers module.

7. Select Save to save your file, then select close to return to Aperture.
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 If you are using Perfect Mask as part of the Perfect Photo Suite, select
Perfect Photo Suite instead, then select Perfect Mask from the module
selector. Don't select multiple images unless you wish to merge them into a
single layered file.

 

You can also access Perfect Mask from the contextual menu by right-
clicking (control-clicking) on an image and selecting Edit with > Perfect
Mask.

 

See also

Supported File Types
User Interface
Navigating the Preview
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User Interface

Click on any tool or control in the window below to learn its function (Adobe Flash Required)

Layers Module

 

 Tip: If you work on a smaller display you can open the close the library with the Command-down arrow (Mac) or Control-down arrow(Win) short-cut.
This gives the preview more room so you can use the Masking Brush.

10 . Getting Started
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Mask Module

See also

Supported File Types
Opening Perfect Mask
Navigating the Preview
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Navigating the Preview

Navigating the Preview

Perfect Mask provides a number of easy ways to navigate and view your image in the Preview window. 

Hand Tool  
The Hand tool is used to drag the image within the Preview window, whenever the image size is larger than the viewable area. 

To pan (scroll) in the Preview screen: 

Select the Hand tool and drag the image until you locate the area you wish to view. 

With any other tool selected press Spacebar while you drag the image in the window.

 

Tip: Hold down the spacebar temporarily to activate the Hand tool no matter what tool is currently selected

Tip: Double-click the Hand tool in the Toolbar to set the image to a magnification that fits completely in the current window size.
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Zoom Tool
The Zoom tool changes the magnification of the image in the Preview screen up to 1600%. 

With the Zoom tool selected:

Click in the Preview window to zoom in and center the image at the location clicked.

Click and drag in the Preview screen to draw a rectangular marquee—the screen fills with the area within the marquee when you release the mouse.

Double-click in the Preview screen to set the Preview screen to 100% magnification.

Hold the Option key (Mac) or Alt key (Win) and click to zoom out.

 

 Tip: Double-click the Zoom tool in the Toolbar to set the image to 1:1 or 100% magnification, showing every pixel. This is best when adjusting textures
and for examining small details.

Navigator and Loupe Pane

 
The Navigator pane gives you a complete birds-eye view of your image. The red region of
interest indicator marks the area of your image that is visible in the preview pane. You can
pan your image by clicking and dragging inside the red region of interest indicator. At the top
of the Navigator pane are several Zoom presets. To activate a Zoom preset simply click on it.

When you toggle to Loupe mode you see a magnified section of the preview under the
cursor. This allows you to judge the quality of your results while maintaining a complete view
of your image.

 

Preview Window Modes
The preview window has several modes, including single image, side-by-side (horizontal or vertical) and split-screen (horizontal or vertical) versions of an image.
This allows you to compare layers side by side or to view a layer mask and the layer side by side. 

12 . Getting Started
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Pressing command (control) L will change the preview mode to Left/Right.

Command-option (control-alt) L will change the preview mode to Left/Right Split screen.

Pressing command (control) T will change the preview mode to Top/Bottom.

Command-option (control-alt) T will change the preview mode to Top/Bottom Split screen.

Pressing command (control) Y will change the view mode to single image.

Pressing command (control) P will toggle the preview on/off for modal modules.

In the tool well there will be an indicator button that shows the current mode, and when pressed toggles to the next mode.  You can also change the mode from
the View menu.

In each side of the preview window you have several options as to what you wish to display. You select what you want to display from a pop-up in the bottom
left corner of each preview pane.

Left or Top (Before Side) Right or Bottom or Single (After Side)

 Overlay (this shows the mask for the current layer)
 White (this shows the mask for the current layer)
 Dark (this shows the mask for the current layer)
 Grayscale (this shows the mask for the current layer)
 Original (default option, Shows the original image)
 Segements (Displays the results from the color segmentation)
Composite (default option, this shows the composite of all enabled layers)

 Overlay (this shows the mask for the current layer)
 White (this shows the mask for the current layer)
 Dark (this shows the mask for the current layer)
 Grayscale (this shows the mask for the current layer)
 Original (default option, Shows the original image)
 Segements (Displays the results from the color segmentation)
Composite (default option, this shows the composite of all enabled layers)

See also

Supported File Types
Opening Perfect Mask
User Interface
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Using Perfect Mask

Perfect Mask's new masking technology makes selecting subjects and isolating backgrounds surprisingly easy. With Automatic Background Removal, an initial
mask is made on your image and can then be fine-tuned using the Erase and Refine Tools. With these new features, you can create high quality masks in just a
few clicks. You'll be amazed at how well this works even when masking tough subjects like hair and glass on complex backgrounds.

Perfect Mask provides several ways to work depending on your user level and the type of image. It works for beginners through advanced users. Below are
example workflows for different user levels.

Simple hard edged subject on a solid background

 

Simple hard edged subjects on a solid backgrounds
are very easy.

1. Start by opening an image into Perfect Mask.

2. Load a new background if desired and place
it under the subject.

3. Switch to the Mask module from the module
selector.

4. Press the Remove Background button in the
Adjust Mask pane. It will detect solid color
backgrounds and remove them
automatically.

5. Press Apply to return to the Layers module
to save your changes.

  

Variegated hard edge subjects with varying backgrounds

A more common situation is a
subject with a more intricate
edge and an inconsistent
background.

1. Start by opening an
image into Perfect
Mask.

2. Add a new background
and align it in the
Layers module.

3. Next select the Mask
module.
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4. Select the Erase Tool
from the toolwell and
loosely brush the areas
you don't want. The
brush strokes will
automatically expand to
similar colors.

 

5. Next select the Refine
Tool and paint over the
edge of the foreground
and background to
remove fringe colors or
small islands of color.

Complex or Semi-Transparent Subject

One of the more difficult
subjects to mask is hair or other
semi-transparent and intricate
subjects against a varied
background. Try these steps for
the best results.

1. Start by opening an
image into Perfect
Mask.

2. Add a new background
and align it in the
Layers module.

3. Next select the Mask
module.
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4. Select the Erase Tool
from the toolwell and
loosely brush the areas
you don't want. The
brush strokes will
automatically expand to
similar colors.

 

5. Next select the Keep
Eye Dropper tool and
select colors in the hair
and body you want to
keep. Focus on the
edge colors.

6. Repeat the process
with the Drop Eye
Dropper for the
background colors.

7. Select the Magic Brush
tool. Set the mode to
Auto, the transition to
128 and the threshold
to zero.

8. Paint over the hair and
border of the body.

9. Use the regular Masking
Brush to touch-up any
mistakes.

10. Press the Apply button.

11. Save your results.

Articles in this section

Preparing Your Image
Background Browser
Understanding Masks
Viewing the Mask
Keep, Drop and Refine Brushes
Magic Brush and Colors
Regular Masking Brush
Clean Up Tools
Pen Tool
Adjust Mask Pane
Lightroom Use
Aperture Use
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Preparing Your Image

To get the most out of Perfect Mask it is best to prepare your composite layers in advance. This means placing your new background as a layer under your
subject (target) layer. This can be accomplished in Photoshop, Perfect Photo Suite or Perfect Mask. Below are instructions to get you started.

Photoshop and Photoshop Elements

16 . Using Perfect Mask
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1. Start by opening your
subject image and
background image.

 

 

 

2. Determine which image
is the correct size and
aspect ratio, either the
subject or background.
In this example the
subject image is the
correct size

3. Select whichever image
is not the correct size,
use the select all
command and the copy
command to copy the
image to the clipboard.

 

 

4. Now return to the other
image and paste the
results as a new layer.

5. In this case, the new
layer is a sky and
should be positioned
under the subject. Drag
it under the subject
layer in the layers
palette. Note that if the
subject layer is a
Background Layer, it
needs to be converted
into a normal layer to
position a layer under
it. Simply double-click on
it to convert it to a
normal layer. 
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6. Next, reduce the
opacity of the upper
layer to 50-70%. This
makes it easier to see
the subject and
background at the same
time.

7. Select the background
layer.

8. Use the transform tool
to size and position the
background correctly
with the subject layer.
Keep in mind you can
always adjust this later
or change to a different
background.

9. Select the subject layer
and return its opacity to
100%. Now you are
ready to start Perfect
Mask.

 

Perfect Photo Suite or Perfect Mask

1. Determine which image
to use as the correct
size and aspect ratio,
either the subject image
or the background
image.

2. Start by opening this
image. In this case, the
foreground image is the
correct size.

 

 

 

3. Next find your
background image and
open it. You will be
prompted to either add
the image as a new
layer or create a new
image. Select the add
as new layer option.

 Tip 1: If you are

18 . Using Perfect Mask
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working from
Lightroom or
Aperture you can
open the first image
into Perfect Photo
Suite or Perfect
Mask, then return to
Lightroom or
Aperture, select
your background
image and send it
Perfect Photo Suite
or Perfect Mask to
merge it in as a
another layer.

 

 Tip 2: If you don't
have a background
of your you like, try
one of the included
backgrounds that
come with Perfect
Mask. From the
Layers module,
select Browse
Backgrounds in the
File menu.

 

 

4. The background will be
added on top of the
foreground, simply drag
it below in the Layers
pane.
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5. Next, reduce the
opacity of the upper
layer to 50-70%. This
makes it easier to see
the subject and
background at the same
time.

6. Select the background
layer.

7. Use the transform tool
to size and position the
background correctly
with the subject layer.
Keep in mind you can
always adjust this later
or change to a different
background.

8. Select the subject layer
and return its opacity to
100%. Now you are
ready to start Perfect
Mask.

 

See also

Background Browser
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Home > Using Perfect Mask > Background Browser

Background Browser

Built-in to the Layers module, is a easy-to-use file browser. You can use it to browse folders just like browsing a web site. It also allows you to quickly browse
the included background library.

You can open multiple browser tabs, each tab browsing a different folder structure

You can drill down into sub-folders by double-clicking

You can move backwards and forwards using the backwards and forwards buttons or the breadcrumbs trail

 To open the Browser and browse a folder select Browser... from the File Menu

If you had open browser folders the last time you used Perfect Mask, they will
automatically appear in the browser when you start.

You can create another browser tab by using the browse option a second time. You
can create as many tabs as you want.

You can open an image double-clicking on it. If you already have an image open,
you have the option of adding the image as a layer or closing the current image
and switching to the one you selected.

If you have multiple images selected in the browser and you want to open them all,
use the Open Selected from Browser option.

To Browse the included Background Library select Browse Backgrounds from the File menu.
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Normally the browser is in filmstrip view. It looks like a horizontal strip of thumbnails. You scroll left and right to reveal images. There are two other modes, which we
will talk about below. 

At the top of the browser are tabs of each each folder structure you have selected to browse. For example you could have one tab with your clients images, another
tab with design elements like your logo and a third for browsing replacement backgrounds. 

You can switch from tab to tab by clicking on the tab you are interested in.

You can close a tab by clicking on the x in the left corner of the selected tab.

If you have more tabs than can be viewed at once in the window, right and left navigation areas appear.

Below the tabs is the breadcrumb navigator. It displays the path of the folder structure. You can use this to quickly move back up a folder structure. It also provides a
graphical representation of the folder tree so you can see where you are at. 

At the left are forward and backward arrows that work just like the forward and backwards arrows in a web browser.

At the right are icons for switching the browser mode. The other modes are detailed below.

Below the breadcrumbs strip are the actual thumbnails. The browser only shows file types that it understands (PSD, PSB, TIF, JPG and RAW). It also shows icons for
sub-folders. 

You can explore a sub-folder by double-clicking on it.

You can change the size of the thumbnails by changing the height of the browser. This is accomplished using the resize handle at the top center of the
browser. You can click and drag on the handle to make the browser area larger or smaller.

When you mouse over a thumbnail a pop-up will display a larger version of the image. This is useful for determining small differences between images without
the need to open the full sized images.

You can not delete, move or rename images in the browser.
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 The browser can also be set to a
matrix view. This is accomplished
by pressing the matrix icon at
the right of the bread crumbs
section. Matrix view is handy
when you have a large number
of images in a folder. Working in
matrix view is the same as film
strip view.

 

 You can also minimize the browser to provide more space to the preview area. This is handy when working on a small display. This is also accomplished by
pressing the minimized icon at the far right of the breadcrumbs section. 

You can toggle between minimized and either film strip of matrix view by double-clicking on a browser tab or by using the command (control) down
arrow keyboard short-cut.

See also

Preparing Your Image
Understanding Masks
Viewing the Mask
Keep, Drop and Refine Brushes
Magic Brush and Colors
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Clean Up Tools
Pen Tool
Adjust Mask Pane
Lightroom Use
Aperture Use
 

Home > Using Perfect Mask > Understanding Masks

Understanding Masks
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 You can think of masking as painting with black paint on white paper. A
white mask reveals all of the layer that the mask is attached to. An all
white mask is considered blank or empty and shows all of the selected
layer. As you use Perfect Mask you are adding black paint (Paint-Out
mode). Where you paint with black you are hiding the current layer,
allowing the layer(s) under it to show through. Think of it like cutting a hole
in the mask. If you make a mistake you can switch your paint color to white
(Paint-In mode) and paint the layer back in like an eraser. When you paint
you have more than just white or black, but any shade of gray in between
depending on the opacity of the brush. Shades of gray partially hide the
layer, blending the layers together. 

Each layer in Perfect Mask has a mask automatically added to it. This
allows you blend each layer differently. Masking in Perfect Layers is done
in a non-destructive, re-editable way that is compatible with Photoshop.
The masking done in Perfect Mask are stored as layer masks which can be
viewed and edited later in Perfect Layers and Photoshop.

There are several global masking options that can be accessed from either
the Masking Brush Inspector or the Mask Menu. They affect the entire
mask on the selected layer.

Reset Mask
Resetting a mask returns it to all white. The entire layer is visible.

Invert Mask
Invert swaps the white for black and black for white. What was hidden is
not revealed and vice-versa. Inverting a mask can be very useful. It
allows you to paint a layer in, rather than out, which is handy if you only
want to work with a small area.

 

See also
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Home > Using Perfect Mask > Viewing the Mask

Viewing the Mask

Perfect Mask allows you to view the mask for each selection area. You can view the mask in several modes, which are accessible from the Show Mask pop-up in
the inspector for each Refine Tool as well as the Masking menu and the bottom left corner of each preview pane. Below are examples of the different mask view
modes. You can toggle mask view on and off with the command (Mac OSX) or control (Windows) plus m keyboard shortcut.
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 Original
Shows the original target layer, with no mask. Think of this as a before image

 Composite
Shows the current layer with the masked areas transparent so you can see the layers under it.
This is what the results will look like when you apply. Think of this as the after image.

 

 Overlay
The masked area appears as 50% red. This is similar to the Quick Mask view in Photoshop

 

 White
The masked area appears as solid white.

 

 Dark
The masked area appears as 90% black.
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 Grayscale
The masked area appears as black, the unmasked areas appear as white. This is the same as
viewing a layer mask in Photoshop.

 

 Segments
Displays the results of the initial segmentation.

 

See also
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Home > Using Perfect Mask > Keep, Drop and Refine Brushes

Keep, Drop and Refine Brushes

Keep and Drop Brushes

When you launch Perfect Mask it starts
by breaking the image down in to small
similar colored segments. The Keep and
Drop Brushes are used to assign
segments to be kept or removed. By
default all segments are marked as keeps
when you open Perfect Mask. The first
step in masking most images is to use the
Drop Brush and make large, lazy brush
strokes through areas you want to
remove. The brush strokes you make will
automatically be expanded to similar
color and textured segments. The Drop
Brush offers a fast way to remove large
sections in a single stroke. The controls
for the Drop Brush are located in the
Drop Brush Inspector, pictured to the
right. If you don't see the inspector on
screen, press the "i" keyboard shortcut
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or press the "i" icon at the bottom of the
toolwell. Below are descriptions of the
controls in the Keep and Drop Brush
Inspector.

Brush Size: Adjusts the size of the
brush. Use a large when for large areas
and a smaller brush to get into the tight
spots.

Edge Refinement: Sets how thick of
an edge is automatically refined. This
smooths out segment artifacts and
reduces color fringing. Generally a
setting of 6-10 works well.

Segment Size: Sets the size, or mass
of the segments that are created. The
default setting of eight works well for
most images. You can see the segments
using segment view. If your image has
few colors and is creating too many
segments will little difference, try a
higher setting. If your image has lots of
colors and gradations use a lower
setting.

Expand Tolerance: The expand
tolerance controls how similar segments
need to be before they are grouped
together.

Wacom Controls: If you are using a
Wacom pressure  sensitive tablet you
can control the brush size with the
pressure.

Show Mask: Enables mask preview for
the main preview pane.

Auto Expand: When enabled,
segments of similar color to those under
the drop brush will be dropped as well.

Use Dropper Colors: When enabled, if
you have set dropper colors with the
Keep and Drop Eyedroppers, those
colors will be used as well, providing
more accurate results.

Remove Background: Attempts to
find a solid color background and remove
it automatically. If you press the button
and nothing happens, your background
is too varied to be removed
automatically. You can increase the
segment size and try again or use the
Drop Brush.

The Keep Brush is used to flip segments
to keep that have been accidentally
marked with the drop brush. You use it in
the same fashion as the Drop Brush.
Think of it as a selective undo for the
Drop Brush.

 

Refine Brush

 The Refine Brush is used to clean up the
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borders between keep and drop
segments as well as intricate areas like
hair, lace, mesh and tree branches.
Once you have removed the majority of
the background with the Drop Brush,
paint the intersection of the subject and
background to refine the border. This will
remove islands of background color and
make the edge more defined. The
controls for the Refine Brush are located
in the inspector palette and are
described below.

Brush Size: This slider adjusts the size
of the brush. Select a brush size that is
just larger than the intersection of the
subject and background. Avoid using
oversized brushes it will take longer to
process and may yield lower quality
results.

Show Mask: Enables mask preview
mode.

Painting Mode: Toggles the painting
mode, either Paint-Out, Paint-In or
Automatic. Automatic is generally the
best choice for this tool. It will paint-in
and out at the same time based on the
colors of surrounding segments.

Use Dropper Colors: If you have
selected keep and drop colors using the
Eye Dropper tools you can add them to
the automatic color selection for more
accurate results.

Use Distance: When enabled, this
option reduces the complexity of the
automatically selected keep and drop
colors. This can make the Refine Brush
more responsive on large images or slow
machines.

Use Local Color: When enabled, the
Refine Brush only uses the segments
under the Refine Brush for determining
colors. On a complex background this will
provide more accurate results.

 

 

See also

 

Home > Using Perfect Mask > Magic Brush and Colors

Magic Brush and Colors

The Magic Brush is the most powerful and precise tool in Perfect Mask. When you are dealing  
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with the most difficult subjects, the Magic Brush is the go-to tool. It works by comparing keep
and drop colors. It protects the keep colors and removes the drop colors. Thinking only in color
and caring about edges or segments allows it to mask through glass, smoke, fog or other
semitransparent, non-sharp edged subjects.

Auto Brushing

There are two ways to use the Magic Brush. The first method is called auto brushing. Start by
selecting the Magic Brush and simply clicking in the background, then brushing into the subject.
The drop color is automatically assigned as the color at the center of the brush  when you click
down. As long as there is a strong difference between the subject and background this can be
a quick way to paint away the background.

 

 Tip: When using the auto brush technique you should have no colors in your Colors
pane. Also make sure the Painting Mode is set to Paint-out only.

Selecting Colors

The second and more precise way to use the Magic Brush is to select colors to keep and drop
using the Eye Dropper tools. The Eye Droppers live in the tool well and are only accessed when
the user interface is set to Advanced Mode. There are two droppers, one for selecting colors to
keep and one for selecting drop colors. It is best to zoom into at least 100% or use the Loupe
tool when selecting colors. When working with selecting colors for the Magic Brush it is best to
work in small, similar colored sections. Avoid selecting every keep and drop in your image. The
keep and drop colors and Magic Brush are global tools, meaning that they don't care what
section of the image you are painting. If you have a color, for example blue, that you want to
remove from the background, but your subjects eyes are blue if you paint over both areas the
background and eyes would be removed.

To deal with with similar colors in different regions you can create different color sets. In the
Colors pane you can create as many keep and drop color sets as needed. 

To create a new color set, press the Add button at the bottom of the Colors pane. You
have the option to create either a new keep, drop or both color sets.

You can also disable a set by clicking on the toggle in its upper left corner.

You can delete a color or a set, depending on your selection by pressing the delete
button.

You can manually adjust a color by double-clicking on it. This will open a color picker
where you can see the color values as well as adjust the color if needed.

Once you have selected the keep and drop colors for your region, brush over it with the Magic
Brush. If the results are not as desired, refine your keep and drop colors and brush over the
region again.

 

 Tip: Keep the number of colors per set to less than six to maintain optimum
performance. You can create as many sets as you need as you work your way
around the image.

 
The Controls for the Magic Brush are located in the Magic Brush Inspector. If you don't see the
inspector, press the "i" key on your keyboard or the "i" icon at the bottom of the toolwell. 

Brush Size: The brush size slider controls the size of the brush. Use the smallest brush
needed.

Brush Feather: The brush feather slider controls the feather, or hardness of the brush. Make
sure you have a feather of at least 25 to blend in retouched areas evenly.

Transition: The transition slider determines how hard the cut-off is between keep and drop
colors. Think of this like feathering. A low transition setting creates a harder edge between the
keep and drop colors. A higher setting will create a softer transition.

Threshold: The threshold slider determines how far away from the exact keep colors are
allowed to be removed. A low threshold setting will keep only the exact colors in the keep pane.
As you increase the threshold, more colors close to the keep colors will be protected. 

 

 Tip: The Transition and Threshold are inter-related to each other. Adjust one slider
may affect the other or limit the range you can select. The Transition must always
be higher than the threshold.
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Wacom Controls: If you have a Wacom pressure sensitive tablet you can adjust the size,
feather or both of the brush with the pressure of the tablet.

Show Mask: Enables mask preview for the main window.

Painting Mode: Toggles the painting mode, either Paint-Out, Paint-In or Automatic. Automatic
is generally the best choice for this tool. It will paint-in and out at the same time based on the
colors of surrounding segments

Use Color Decontamination: When enabled, Perfect Mask will attempt to remove the drop
color component from semi-transparent areas. This can be helpful for reducing color fringing
and spill colors when working on blue or green screens.

See also
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Home > Using Perfect Mask > Regular Masking Brush

Regular Masking Brush

The Masking Brush in Perfect Mask is similar to Masking Brush in Perfect Layers. It functions like a brush tool in most drawing or painting applications. The
Masking Brush is useful for removing large areas quickly, touching up difficult areas of a mask, or for painting mistakes back in. When you select the Masking
Brush, your tool icon changes to a circle that represents the size of the brush. It may also appear as two concentric circles, indicating the inner hard edge and
outer soft edge of the brush if the feather control is set above zero. 

To use the Masking Brush, select it in the tool well.  Then check your brush mode and make sure it is set to Paint-Out. Now you are ready to mask, simply paint
on the image in the areas you wish to hide. As you brush you will see the underlying layer(s) appear. If you make a mistake while brushing you have several
options to correct them:

First you can use the Undo command from the edit menu. This will undo the last segment of the brush stroke you have created.

You can undo an entire stroke by using the Undo Stroke command from the edit menu.

You can toggle the paint mode to Erase and brush over your mistake.

Below are details on how to control the Masking Brush.

This is the Masking Brush Inspector. It contains the controls
for the Masking Brush as well as several global masking
options. 

Show Mask: Enables a preview of the mask in the main
window.  

Paint Mode: The paint mode toggle controls the shade of
gray you paint with. When set to Paint-Out, you are
painting with black paint and you will hide areas of the layer
you paint. If you make a mistake you can toggle to the
Paint-In option, which paints with white paint and removes
brushing to reveal the current layer. You can toggle the
paint mode with the x keyboard shortcut.

Invert Mask: Invert swaps the white for black and black
for white. What was hidden is not revealed and vice-versa.
Inverting a mask can be very useful. It allows you to paint
a layer in, rather than out, which is handy if you only want
to work with a small area. You can invert the mask with the
command (Mac OS X) or control (Windows) i keyboard
shortcut.

Reset Mask: Reseting a mask returns it to all white. The
entire layer is visible.

 

 Brush Size  
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You can control the size of the brush using the Brush Size
Slider.  You use a small brush at high magnification for
precise work and and a large brush at fit to screen for
general work. To the right you can see examples of brush
strokes are varying sizes. You can control the size of the
brush several ways:

Use the Brush Size Slider

Use the left and right bracket keys ( [  ] )

Use your mouse scrollwheel (if your preferences
are set to this)

Use your Wacom pressure sensitive tablet

 Brush Feather
You can control the amount of feathering or hardness of
the brush using the Feather Slider. The feather has range
from 1 to 100 percent. You use a small feather at high
magnification for precise, hard-edged work and and a
large, soft-edged brush at fit to screen for general work.
You can visually see your feather by watching the outer
concentric circle of the brush tool. To the right you can see
examples of different feather options. You can control the
size of the brush several ways:

Use the Feather Slider

Use the shift + left and right bracket keys ( [  ] )

 

 Brush Opacity
You can control the opacity, or strength of the brush with
the Opacity Slider. Think of the opacity as the shade of
gray you are painting with. The opacity has a range from 1
to 100 percent. You use a high opacity to paint quickly and
hide large areas. You use a lower opacity for blending
areas together or for subtle work. To the right you can see
examples of different opacity options. You can control the
size of the brush several ways:

Use the Opacity Slider

Use the option (Mac OSX) or alt (Windows) + 0-9
keys

Use your Wacom pressure sensitive tablet

 

 Tip: Perfect Mask's Masking Brush behaves
differently than the Masking Brush in other
onOne products. It uses a constant opacity,
rather than cumulative. That means if you are
painting with 50% opacity and you brush over
the same area twice, the opacity will remain at
50%, rather than increasing to 75% like it
would in other tools. This makes it easier to
produce a consistent touch-up mask.
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 Wacom® Controls
Perfect Layers supports pressure sensitive Wacom tablets.
You can use a tablet like a standard mouse for general
control. When you use the Masking Brush you can also
enable special pressure sensitive controls for the brush
size, brush opacity or both at the same time. The harder
you press the greater the size or opacity will get. You can
set the maximum value you want using the Brush Size and
Opacity sliders. To the right you can see examples of how
pressure sensitivity can be used to control the Masking
Brush.
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Clean Up Tools

Perfect Mask features several handy clean-up tools. The clean-up tools are located towards the bottom of the toolwell on the left side of the screen. The clean-
up tools are the chisel, blur and bucket.

Chisel Tool

The Chisel tool is used for
removing fringes or halos along
hard edges. Fringes are
common when the background
to be removed is brighter than
the foreground. The chisel
works like a chisel or plane in a
wood shop. It removes just a
sliver along the edges. The
chisel tool only works on the

 

Using Perfect Mask . 31

 

Perfect Mask 5 User Guide



edges so you don't have to be
careful with it.

Chisel Size: Adjusts the size of
the chisel tool. Feel free to use
a large chisel to make brushing
fast. The size of the chisel does
not affect how much is chiseled
off.

Chisel Hardness: Adjusts how
sharp the edge created by the
chisel is. The higher the amount,
the softer the edge.

Chisel Amount: Controls the
amount, or depth of the chisel.
Use the lowest amount needed
to maintain as much detail as
possible. 

Wacom Controls: Allows you
to adjust the chisel size or chisel
hardness with the pressure
sensitivity control.

Painting Mode: Painting-out
will remove pixels, Paint-in will
add pixels back

  Tip: You can double-
click on the chisel
tool icon in the
toolwell to apply the
chisel to the entire
image.

 

 

 

Blur Tool

The Blur tool is similar to the
chisel, but rather than
removing edge pixels, it
softens or blurs them.
Softening the edges on blurred
or semi-transparent subjects
like hair can make them blend
with a new background in a
more realistic manner.  The
blur tool only works on the
edges so you don't have to be
careful with it.

Brush: Adjusts the size of the
blur tool. Feel free to use a
large size to make brushing
fast. The size of the brush
does not affect the blur
amount.

Brush Feather: Adjusts how
sharp the edge between the
blurred and sharp area is. The
higher the amount, the softer
the edge.

Blur Amount: Controls the
amount of blur. Use the lowest
amount needed to maintain as
much detail as possible. 

Wacom Controls: Allows you
to adjust the brush size or
feather with the pressure
sensitivity control.
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 Tip: You can
double-click on the
blur tool icon in the
toolwell to apply it
to the entire image.

 

Bucket Tool

The Bucket Tool is used to
remove large areas quickly.
Simply click in any isolated area
to remove it completely. It is
important that the area to be
removed has a completely
transparent margin around it, or
the entire image will be removed
instead.

Painting Mode: Controls
whether the bucket tool is to
remove (Paint Out) or replace
(Paint-In) the area that is
clicked on.
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Pen Tool

 The Pen Tool is very different from the rest of the tools in Perfect Mask.
Rather than working based on color, it works by detecting and tracing
edges. It is useful for when you have large hard-edged areas or if the
difference in color between the subject and background are too close
together for the color based tools to work. The Pen creates a path, or
selection. When you complete a path you have the option to remove
either what is inside or side of the path. The controls for the Pen Tool are
located in the inspector. The Pen has two working modes, magic and
classic.

In magic mode, the default, the pen attempts to detect and trace edges.
It works well when there is a significant difference between the subject
and background and the edge is variegated such as a mountain.

In classic mode, the pen draws straight lines from point to point that you
click. You can force classic mode by toggling the Classic Pen check-box, or
by holding down the shift key.

Magnetic Area: Adjusts the size of the area that the pen tool looks at to
detect an edge. Use as small a magnetic area as possible while being
practical.

Edge Attraction: Adjusts how precise or tight the path is to the edge. If
you have a highly variegated subject use a high setting of 100 or more. If
you subject is mostly straight or curved edges, like a building try a lower
setting to create cleaner, straighter lines. 

Edge Mask: Adjusts the hardness of the edge that is created when you
select the region to remove. The lower the setting, the harder the edge.

Wacom Controls: If you are using a Wacom pressure sensitive tablet
you can control the size of the magnetic area or the edge attraction with
the pressure of the tablet.
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Painting Mode: Controls whether you will remove or replace the region
when you apply the pen results.

Classic Pen: When enabled, the pen only draws straight lines between
points when you click. This is useful when working on straight lined
subjects like architecture or when the boundary of the subject and
background are ambiguous and need an artists interpretation. 

To use the Pen Tool, start by selecting it in the toolwell. Then click and hold
at the edge you want to trace. Then move the pen along the edge. You
will see that the path is attracted to the edge and attempts to trace it.

If you make a mistake, just trace backwards and the path will
change.

If you let go, click on the last point and continue to work with the
path.

You can manually push the path where you like by clicking in the
middle and tugging it like a string.

If you encounter an area where the pen will not detect the edge
automatically, try holding down the shift key and drawing straight
line segments until the edge becomes hard again.

 

You must complete a path by returning to the starting point to be able to
remove the selected area. To complete the path, hold down the shift key
and move your cursor back over the starting point. A red circle will appear
and the text "Click now to close the path" will appear. Click to close the
path. 

 

When the path is complete the pen tool will turn into a gavel with either a
minus or plus symbol. Click in the region, either inside or outside the path
to remove an area. If the gavel has a plus icon, rather than minus it is set
to Paint-in, instead of paint-out. Just change the mode in the inspector. If
the edge is too hard or too soft, use the undo command, adjust the Edge
Mask slider in the inspector and click again in the region you want to
remove. 

 

See also

Preparing Your Image
Background Browser
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Home > Using Perfect Mask > Adjust Mask Pane

Adjust Mask Pane

 The Adjust Mask Pane contains several important controls that affect the entire mask or how
Perfect Mask is applied.

Adjustments: The Adjustments button opens the Adjust Mask dialog, pictured below. This
dialog contains several global mask adjustments.

Remove Background: Attempts to find a solid color background and remove it automatically.
If you press the button and nothing happens, your background is too varied to be removed
automatically. You can increase the segment size and try again or use the Drop Brush.

Apply As: Sets how Perfect Mask is applied. 

You can apply the results to the current layer, permanently removing pixels. This is
generally not recommended.

New Layer, this is safer as the original image is preserved, but you can not readjust
the mask. This is generally not recommended

Layer Mask, this is the default setting. The mask is stored as a re-editable, non-
destructive layer mask. Layer masks are supported by Perfect Layers, Perfect Photo
Suite and Photoshop.

Copy with Layer Mask. This is the safest option. It applies the mask as a  re-editable,
non-destructive layer mask on a copy of the original layer. keep in mind that if you use
color decontamination you are also changing the color of the layer, not just the
transparency so this option is the most flexible.

 

Adjust Mask Dialog

Accessed from the Adjust Mask pane, the Adjust Mask dialog contains several global mask
adjustments.

White Contrast: Sets the white clip point of the mask. This is useful for reducing haze that
shows too much of the original layer.

Black Contrast: Sets the black clip point of the mask. This is useful for reducing haze that
shows too much of the new background layer.

Feather: Softens the edge of the mask globally. Generally this is better accomplished in a
selective way using the blur tool.

Grow/Shrink: Increases or decreases the size of the mask. Shrinking the mask globally can
remove minor fringes but may sacrifice small details such as hair. Generally this is better
accomplished in a selective way using the chisel tool.

Reduce Noise: Looks for and reduces noise in the mask caused by a noisy, grainy image or
dust on the camera sensor.
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Lightroom Use

 To Apply Perfect Mask with manual, custom interaction to an image or group of images in Photoshop Lightroom follow these instructions:

1. Open Photoshop Lightroom

2. Select the image that will act as the base image. This can be the subject or background but should be the size and aspect ratio of the final art piece

3. Go to File > Plug-in Extras

4. Select Perfect Mask

5. Perfect Mask will appear, in the Layers module.

6. Now return to Lightroom and select the next image, either the background or subject and repeat step 5. (If you have started with your subject and
wish to use a background from the background library in Perfect Mask skip this step)

7. Adjust the layer order, size and position to place your subject on top of the background. See the preparing your image section for more details.

8. Now select Mask from the module selector.

9. Perform your masking tasks, the press Apply

10. You will be returned to the Layers module, select Save and Close and you will be returns to Lightroom.

 

 Tip: The file handing when working in Lightroom is controlled in the Preferences. 

 

 Tip: If you have the Perfect Photo Suite, you access Perfect Mask through it inside of Lightroom. You will see Perfect Photo Suite instead of Perfect
Mask in the Plug-In Extras menu. Don't select multiple images in Lightroom unless you want to stack them into a single layered file. See the Opening
Perfect Mask section. 

 

See also

 

Home > Using Perfect Mask > Aperture Use

Aperture Use

 To Apply Perfect Mask with manual, custom interaction to an image or group of images in Aperture follow these instructions:

1. Open Aperture

2. Select the image that will act as the base image. This can be the subject or background but should be the size and aspect ratio of the final art piece

3. Go to Image and select Edit With...

4. Select Perfect Mask

5. Perfect Mask will appear, in the Layers module.

6. Now return to Aperture and select the next image, either the background or subject and repeat step 5. (If you have started with your subject and
wish to use a background from the background library in Perfect Mask skip this step)

7. Adjust the layer order, size and position to place your subject on top of the background. See the preparing your image section for more details.

8. Now select Mask from the module selector.

9. Perform your masking tasks, the press Apply

10. You will be returned to the Layers module, select Save and Close and you will be returns to Aperture.

 

 Tip: The file handing when working in Aperture is controlled in the Aperture Preferences. For the best results set your external editor format to 16 bit
PSD and select a large color space like Adobe RGB 1998. 

 

 Tip: If you have the Perfect Photo Suite, you access Perfect Mask through it inside of Aperture. You will see Perfect Photo Suite instead of Perfect
Mask in the Plug-In Extras menu. Don't select multiple images in Aperture unless you want to stack them into a single layered file. See the Opening
Perfect Mask section. 

 

See also
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Preferences & Settings

The preferences dialog for Perfect Mask is shared with other members of the Perfect Photo Suite. It contains general application settings that are used by
Perfect Mask. The Perfect Mask preferences are accessed from the Perfect Mask or Perfect Photo Suite menu on Mac or the Edit menu on Windows.  The
preferences contain the following controls:

General Settings
 

1. Working Color Space: When a file is opened in standalone mode
and has no color profile associated with it, this is the assumed
color profile for the image. Images that come from other hosts or
have tagged or embedded profiles will use the associated profile
instead.

2. Scrolling Controls: Let's you select how the mouse scrollwheel or
scrolling gesture works. The options are:

1. Adjust Zoom: Adjusts the zoom of the preview window.
Scrolling up increases the zoom, scrolling down decreases
the zoom. It is important that the zooming is comfortable,
not too fast or slow or jerky.

2. Pan Image: Pans the image, like using the pan tool or
navigator. It is important that the panning is comfortable,
not too fast or slow or jerky.

3. Adjust Tool Size: Adjusts the size of the current tool if
relevant, such as a brush tool.

3. Preview Background Color: You may select the color of the
background behind the preview image. The default color is black.
There should be options for black, white, light gray, dark gray and
custom... The custom option a color picker where you can select
your own background color.

 

Lightroom Plug-In Settings

 

1. Color Space: Specifies the color space to use when processing
copies from Lightroom. This is similar to the working color space
pop-up in the general preferences tab, however there are only
the three options supported by Lightroom: sRGB, Adobe RGB 1998
and ProPhotoRGB.

2. Bit Depth: Sets the bit depth for the copies created by Lightroom,
the options are 8 and 16 bit.

3. Resolution: Sets the resolution of copies created by Lightroom.

4. Stack with Original: Enabled by default, copies created by
Lightroom are stacked with their original or source image.

5. Use Original for Single PSDs. Enabled by default. If your selection
is a single PSD file, the original PSD is opened rather than creating
a copy.

 

Mask Pro Specific Settings
There is a settings dialog located in the Edit menu which contains settings specific to Perfect Mask
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1. Remember tool mode for each tool: When enabled, the tool mode
(Paint-In, Paint-out, Auto) is remembered for each tool rather
than a global basis.

2. Segment Scaling: When Perfect Mask opens, it segments the
image into many small similar colored irregular segments. The
number of, and thus the precision of segments is determined on
the number of processing cores and the segment scaling
preference. The default setting, Smaller will be the fastest and
will take about ten seconds to process. Selecting the Medium or
Large option will take longer to load but will create smaller, more
precise segments.

 

See also

Welcome
Installation
What is New Perfect Mask
Getting Started
Using Perfect Mask
Menus
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Perfect Mask File Edit Mask View Window

Help Keyboard Shortcuts

 

Home > Menus

Menus
Pages in this Section

 

 

Home > Menus > Perfect Mask

Perfect Mask

About...: Opens the about box. This dialog contains your serial number, version number and
information on contacting onOne Software for support.

Preferences...: Opens the preferences dialog.

Quit: Quits the application

 

 

 Tip: On Windows, the preferences can be found in the Edit menu, the About Box can be found in the Help menu.

See also

File
Edit
Mask
View
Window
Help
Keyboard Shortcuts
 

Home > Menus > File

File

Apply: Applies the current settings and options to your image and returns to the host application.

Cancel: Cancels Perfect Mask and returns back to the host application with no changes.
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See also

Perfect Mask
Edit
Mask
View
Window
Help
Keyboard Shortcuts
 

Home > Menus > Edit

Edit

Undo: Reverses the last user action

Redo: Reapplies the last user action if it has been undone. 

Undo Stroke: If the last action was a brush stroke, this reverses the entire brush stroke

Redo Stroke: If you last action was an undo of a Brush Stroke, this reapplies the entire stroke

Reset All: Resets all the floating palette controls back to their default settings.

Settings: Opens the Perfect Mask specific settings.

Preferences (Windows Only): Opens the Perfect Mask preferences dialog.

See also

Perfect Mask
File
Mask
View
Window
Help
Keyboard Shortcuts
 

Home > Menus > Mask

Mask

Show Mask: Flyout menu with mask preview options.

Reset Mask: Resets the mask to all white, revealing all of the target layer.

Remove Background: Attempts to remove the background automatically. If the background is consistent in
both color and texture Perfect Mask may be able to remove it automatically. If you select this option and nothing
happens, then the background is too small or complex to be removed automatically.

 

 

See also

Perfect Mask
File
Edit
View
Window
Help
Keyboard Shortcuts
 

Home > Menus > View

View

Zoom In: Zooms the preview window in one increment. This will make the preview image larger.

Zoom Out: Zooms the preview window out one increment. This will make the preview images smaller.
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Fit to Screen: This sets the preview image so that the entire image is on screen at once. Think of this as an
overview of the entire image. This is the setting you will use most of the time.

Actual Pixels: This sets the preview image so that it zooms to actual pixels or 1:1 also called 100%. This
setting allows you to see every pixel in the image. This is useful when making precision adjustments.

Preview Area Mode

Single Image: Sets the preview area to show a single image.

Left/Right: Sets the preview area to show a side-by-side compare of your before and after image. This is the
default mode.

Left/Right Split: Sets the preview area to show a split-screen preview of your before and after results on a
single image.

Top/Bottom: Sets the preview area to show a side-by-side compare of your before and after image. This is
the default mode.

Top/Bottom Split: Sets the preview area to show a split-screen preview of your before and after results on a
single image.

 

See also

Perfect Mask
File
Edit
Mask
Window
Help
Keyboard Shortcuts
 

Home > Menus > Window

Window

Window Mode: Sets the window mode, Basic or Advanced.

Navigator: Hides or shows the navigator pane.

Adjust Mask: Hides or shows the Adjust Mask pane.

Colors: Hides or shows the Colors pane.

Show/Hide Inspector: Opens or closes the inspector.

Welcome Dialog: Opens the Welcome Dialog which shows basic step-by-step instructions for using Perfect
Mask.

 

See also

Perfect Mask
File
Edit
Mask
View
Help
Keyboard Shortcuts
 

Home > Menus > Help

Help

Search: Not used, Mac OSX only

Perfect Mask Help...: Opens this html help in your default web browser.

Perfect Inspiration...: Opens the default web browser and navigates to the Perfect  
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Inspiration Gallery at the onOne website.

Check for  Updates...: Checks with the onOne update server to see if you are running the
current version. If there is a newer version you will be notified and be walked through the
update process.

Activate/Deactivate: Opens the activation dialog. These are used to deactivate your
software for moving it to another computer or for a return.

Registration: Opens the default web browser and navigates to the registration page of the
onOne website.

Show Keyboard Shortcuts...: Opens the keyboard shortcut inspector.

About Perfect Mask (Windows Only): Opens the about box with the version number and
license code displayed.

See also

Perfect Mask
File
Edit
Mask
View
Window
Keyboard Shortcuts
 

Home > Menus > Keyboard Shortcuts

Keyboard Shortcuts

Perfect Mask has many keyboard short-cuts to make it faster to access common buttons and menu items. It also uses many of the keyboard shortcuts that
Photoshop uses, making it intuitive to learn. Here is a list of the most commonly used keyboard shortcuts:

Layers Module

Action  Mac  Win

 New File  cmd n  ctl n

 Open  cmd o  ctl o

 Open as Layer  cmd shift o  ctl shift o

 Save  cmd s  ctl s

 Save As  cmd shift s  ctl shift s

 Export  cmd shift e  ctl shift e

 Preferences  cmd ,  ?

 Undo  cmd z  ctl z

 Undo Stroke  cmd opt z  ctl alt z

 Redo  cmd shift z  ctl shift z

 Redo Stroke  cmd shift opt z  ctl shift alt z

 Cut  cmd x  ctl x

 Copy  cmd c  ctl c

 Paste  cmd v  ctl v

 Open/Close Navigator Panel  cmd 1  ctl 1

 Open/Close Layers Panel  cmd 2  ctl 2

 Open/Close Masking Panel  cmd 3  ctl 3

 Minimize/Restore Browser  cmd down arrow  ctl down arrow

 Delete Layer  del  del

 Select Pan Tool  h  h

 Select Zoom Tool  z  z

 Select Trim Tool  t  t

 Select Move Tool  v  v

 Select Masking Brush  b  b

 Select Masking Bug  m  m

 Zoom-In  cmd + or cmd =  ctl + or ctl =

 Zoom-Out  cmd -  ctl -

 1:1  cmd opt 0  ctl alt 0

 Fit to Screen  cmd 0  ctl 0
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 Fit to Layer  cmd shift 0  ctl shift 0

 Brush Size
 larger ]
smaller [

larger ]
smaller [

 Brush Feather
softer shift ]
harder shift [

softer shift ]
harder shift [

 Brush Opacity

opt 1 (10%)
opt 2 (20%)
opt 0 (100%)
etc

opt 1 (10%)
opt 2 (20%)
opt 0 (100%)
etc 

 Layer Opacity

1 (10%)
2 (20%)
0 (100%)
etc

1 (10%)
2 (20%)
0 (100%)
etc

 Show Mask  cmd m  ctl m

 Toggle Mask View  cmd opt m  ctl alt m

 Invert Mask  cmd i  ctl i

 Duplicate Layer  cmd j  ctl j

 Merge Layer  cmd e  ctl e

 Merge Visible  cmd shift e  ctl shift e

 Constrain Prop  shift drag on corner  shift drag on corner

 Grow from center  opt drag on corner  alt drag on corner

 Toggle Paint-In/Paint-Out/Erase  x  x

 Toggle Single View Preview  cmd Y  ctl Y

 Toggle Left/Right Preview  cmd L  ctl L

 Toggle Left/Right Split Preview  cmd opt L  ctl alt L

 Toggle Top/Bottom Preview  cmd T  ctl T

 Toggle Top/Bottom Split Preview  cmd opt T  ctl alt T

Mask Module

Action  Mac  Win

 Apply  cmd s  ctl s

 Cancel  esc, cmd w, cmd .  esc, ctl w

 Preferences  cmd ,  ?

Undo  cmd z  ctl z

 Redo  cmd shift z  ctl shift z

 Cut  cmd x  ctl x

 Copy  cmd c  ctl c

 Paste  cmd v  ctl v

 Reset All  cmd opt z  ctl alt z

 Switch to Pane  cmd 1,2,etc.  ctl 1,2,etc

 Select Pan Tool  h  h

 Select Zoom Tool  z  z

 Select Keep Brush  k  k

 Select Drop Brush d d 

 Select Refine Brush  r  r

 Select Masking Brush  b  b

 Select Magic Brush  m  m

 Select Keep Dropper   

 Select Drop Dropper   

Select Pen Tool  p  p

 Select Chisel Tool  c  c

 Select Blur Tool  l  l

 Select Bucket Tool  s  s

 Zoom-In  cmd + or cmd =  ctl + pr ctl =

 Zoom-Out  cmd -  ctl -

 1:1  cmd opt 0  ctl alt 0

 Fit to Screen  cmd 0  ctl 0

 Fit to Layer  cmd shift 0  ctl shift 0
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 Tool Size
 larger ]
smaller [

larger ]
smaller [

 Tool Feather
softer shift ]
harder shift [

softer shift ]
harder shift [

 Tool Opacity

opt 1 (10%)
opt 2 (20%)
opt 0 (100%)
etc

opt 1 (10%)
opt 2 (20%)
opt 0 (100%)
etc 

 Toggle Paint Mode (paint-in, paint-out)  x  x

 Show/Hide Mask  cmd m  ctl m

 Toggle Mask View  cmd opt m  ctl alt m

 Preview Modes
  - Single Image
  - Left/Right
  - Left/Right Split
  - Top/Bottom
  - Top/Bottom Split

 
cmd Y
cmd L
cmd opt L
cmd T
cmd opt T

 
ctl Y
ctl L
ctl opt L
ctl T
ctl opt T 

See also

Perfect Mask
File
Edit
Mask
View
Window
Help
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